VSCode之Java环境安装

需要本机安装好java、tomcat、maven等工具。
## 官方教程
https://code.visualstudio.com/docs/languages/java

## 开发插件
Java Extension Pack
Tomcat for Java
Maven for Java
Mysql

## 其他插件
background-cover

## 报错
### Java 11 or more recent is required to run. Please download and install a recent JDK
![](https://img2020.cnblogs.com/blog/1208477/202008/1208477-20200807165217373-1887393555.png)
原因:
是由于Language Support for JAVA插件在2020年7月22日更新到0.65.0预览版,不再支持jdk8。
解决方法:
1.安装回0.64.1预览版及以前的版本.右击Language Support for Java(TM) by Red Hat->选择安装另一个版本,输入64.1
2.禁用插件自动更新,在设置中搜索Extensions Auto Update,取消自动更新。

点赞

Leave a Reply

Your email address will not be published. Required fields are marked *